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TIP 1 - An in-depth look at simulating truss movement in wysiwyg

In this month’s tip, you will learn how to simulate the movement of a length of truss that would be hung from two motors in real life. 
Since the motors are controlled independently, they can be used to raise/lower the truss, as well as tilt it around its center point.

The key to simulating this movement is to attach the truss to a Rotation Axis, which is then attached to a Linear Axis. Note that if this is 
lighting truss, you must hang the fixtures on it and focus them (in the case of conventionals) before you attach the truss to any axes.

Truss details for this example 

In this example, we will use truss that has the following properties:
length: 16’•	
minimum trim height when horizontal:  20’ •	
maximum trim height when horizontal:  30’•	
at any time, the truss will be able to tilt up to 45º clockwise and/or counter-clockwise; when fully tilted, either end of the truss will •	
be able to “dip” below the minimum horizontal trim height of 20’
it will hold two moving lights and two conventionals. (The two conventionals will be used to light the subject (a 6’ ladder) when •	
the truss is horizontal at minimum and maximum trim respectively. The two moving lights can be used at any time, since      
wysiwyg has the ability to “track” static focus positions and update fixture positions automatically.)

Before you begin

Before you start, perform the following general setup or create something else entirely. For details on any of these steps, see the  
wysiwyg online Help or Reference Guide.

In CAD mode, start a new file and insert a Black Box venue.1.	
Insert a 6’ Ladder from the Library a few feet up from the middle of the venue, on the floor.2.	
Draw a focus position in the middle of the ladder roughly 3’ off the floor.3.	
Assemble two sections of truss (for example, two 8’ sections of Christie 12” Box Truss) at a trim height of 20’.4.	
On the truss, hang two ERS fixtures (for example, 14º and 19º ETC Source 4s) and two moving lights of your choice (for ex-5.	
ample, Martin Mac 500s).

Focusing the fixtures

Once you hang the fixtures, you must focus the ERS fixtures as per the requirement set above. The 19º fixture will light the ladder when 
the truss is horizontal and at minimum trim, while the 14º fixture will light the ladder when the truss is horizontal and at maximum trim. 

Dany Tancou
 * All the pictures that illustrate this article are from wysiwyg Release 24, your project might look a 
bit different if you are using Release 23.
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To focus the 19º fixture

Select the Focus Position that you drew in the middle of the ladder (step 3 above).1.	
Click Tools > Quick Focus2.	 .
Click on the 19º ERS fixture.3.	

Result:  The fixture now points at the Ladder.

To focus the 14º fixture

Before you focus the 14º fixture, you must temporarily move the truss to the 30’ trim height. The easiest way to achieve this is with an 
Absolute move, as described below.

Select the truss.1.	
Click 2.	 Edit > Move.
Without clicking, type 3.	 @0,0,10’ and press ENTER.

Result:  The truss moves up by 10’.

Focus the fixture:

Select the Focus Position that you drew in the middle of the ladder.4.	
Click Tools > Quick Focus.5.	
Click on the 14º ERS fixture.6.	

Result:  The fixture now points at the Ladder.

Move the truss back to its minimum trim position:

Select the truss.7.	
Click 8.	 Edit > Move.
Without clicking, type 9.	 @0,0,-10’ and then press ENTER.

Note that these steps (i.e. focusing conventional fixtures with the truss at different heights) replicate those performed in real life. Since 
these fixtures can only be focused manually, they must be focused from the position at which they are going to be used.  

Your setup should now look something like the following screenshot:

Tips & Tricks - #1 Continued
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Drawing the Axes
Now you must draw the two axes used to simulate the truss moving and tilting. As noted above, to simulate this movement, the truss 
must be attached to a Rotation Axis (which simulates tilting), which is then attached to a Linear Axis (to simulate the up/down move-
ment).  

To draw the Rotation axis

In CAD mode, switch to Front View. 1.	
From the Draw menu, select 2.	 Axis > Rotation Axis.
Type a name for this axis (for example, “Truss_Tilt”).3.	
Click 4.	 Tools > Snap > Endpoints. (Endpoint snap ensures that the “Tilt” Rotation Axis is placed at the exact mid-point of the 
truss, where the two pieces meet.)
Hover your cursor at the top edge of the truss, where the two pieces meet, and wait for it to snap into place, as shown below:  5.	

Click to place the Rotation axis.6.	
           Result: The Rotation axis appears in your drawing.  

To draw the Linear axis

Still in Front View, from the Draw menu, select 1.	 Axis > Linear Axis.
Type a name for this axis (for example, “Truss_Move”).2.	
Click 3.	 Tools > Snap > Endpoints.
Again, hover the cursor at the top edge of the truss, where the two pieces meet. Wait for it to snap into place, and then click to 4.	
begin drawing the Linear axis. 

Before clicking again, click 5.	 Tools > Ortho > Z Axis.
Move the mouse towards the top of the screen (a line will begin to extend upwards), and then type 6.	 10’ and press ENTER.
Right-click and select 7.	 Finish Axis.

Result: The Linear axis appears in your drawing, as shown in the graphic below:

Tips & Tricks - #1 Continued
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Attaching the Truss to the Axes

Before attaching the truss to the axes, you must make sure that the truss is able to tilt both ways, as per the requirement above. When 
working with a Rotation axis, the rotation of anything attached to it begins at the tip of the arrow and continues counter-clockwise until 
it reaches the tip of the arrow again.  As such, if you were to attach the truss to the Rotation axis in the position shown above, the truss 
would never be able to tilt clockwise.

Therefore, you must rotate the truss by -43.2º around the same end point where you inserted the Truss_Tilt axis. If you do not perform 
this step, due to the way in which wysiwyg uses axes, you will only be able to rotate/tilt the truss counter-clockwise.  

To maintain the fixture focus position

There is one last thing left to do before you rotate the truss to set its rest position:  you must make sure that the two conventional 
fixtures maintain their focus position even after you rotate the truss. Failure to do so before the truss is rotated will result in loss of the 
fixtures’ Pan and Tilt information. 

Select 1.	 one of the fixtures.
        IMPORTANT: Do not select both fixtures at the same time.

Right-click and select 2.	 Properties.
Click the 3.	 Fixture tab.
On the 4.	 General sub-tab, from the Focus Position drop-down, select None.
Without touching anything else5.	 , click OK.
Repeat steps 1–5 for the other fixture. 6.	

Result: Even though you removed the association with the “Ladder” Focus Position, the fixtures have maintained the Pan and Tilt 
values that were assigned to them when they were initially associated with this Focus Position.

To rotate the truss

Still working in Front View, select the truss.1.	
From the Edit menu, select 2.	 Rotate.
Click 3.	 Tools > Snap > Endpoints.
Hover the cursor at the top edge of the truss where 4.	
the two pieces meet. Wait for it to snap into place, 
and then click to set the base point for the move.
Type 5.	 -43.2 and press ENTER.

Result: The truss rotates clockwise. The conven-
tional fixtures are no longer lighting the ladder, which is 
fine because the requirement is that they only do so when 
the truss is horizontal. They will light the ladder once you 
start setting up Looks in Design mode.  

Now that the truss has been rotated and you are about to 
attach it to the axes, it must remain in this position oth-
erwise it will not move properly.  This should not present a 
problem, except when printing the plot.  Printing with the 
truss in this position would make the plot hard to read, to say 
the least.  Therefore, it is recommended to set up the truss 
for movement only after the design has been finalized (and 
the plot was printed).  Alternately, you could keep two copies 
of the file, one for previsualization and one for printing.

Why use the -43.2º angle?

It is known that wysiwyg’s Scenery Designer Tool (in Design mode) only uses whole 
numbers, from 0 to 100--it does not use decimal values. Therefore, to use this Designer tool 
effectively, you must “translate” the rotation angle (0º to 360º) into numbers that the tool can 
handle (again, 0 to 100).  

If the Scenery Designer Tool could use decimal values, you could start with the truss’s rest 
position at -45º, and, to tilt it to  a perfectly horizontal position  (i.e.to 0º) set the position for 
the rotation axis in Scenery Designer tool to 12.5.  Since this cannot be done, another solu-
tion must be devised.

It is known that a 45º rotation is equal to one eighth of a turn (360º / 45º = 8) and that one 
eighth of 100 is 12.5 (100/8=12.5).  Since a position of 12.5 is not achievable on the Scenery 
Designer Tool, you must compensate in the angle of the truss’s rest position.  
 
To determine what this angle is, use cross-multiplication (to solve for X):  since you know 
that a position of 12.5 on the Scenery Designer Tool would rotate the truss from -45º to 0º, 
what angle do you need to start at to get to the same end angle with a position of 12 on the 
Scenery Designer Tool?  

In other words, 12.5 is to 45º as 12 is to Xº.  To solve for X, multiply 12 by 45º and divide by 
12.5:  

X = 12*45º/12.5 = 43.2º
 
Hence, making the truss’s rest position -43.2º and giving it a position of 12, will bring it to a 
perfectly horizontal position.

Tips & Tricks - #1 Continued
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To attach the truss to the axes

Finally, you attach the truss to the axes, so you can start to play with the moving truss in Design mode!

Click to select the truss, and then right-click and select 1.	 Properties.
On the General tab, from the 2.	 Attach to Axis drop-down, select the Rotation axis you created (for example, “Truss_Tilt”).
Click 3.	 OK.
Click to select the Rotation axis, and then right-click and select 4.	 Properties.
On the General tab, from the 5.	 Attach to Axis drop-down, select the Linear axis you created (for example, “Truss_Move”).

Click OK.
 
 
Creating Looks in Design mode

Now that you have set things up, switch to Design mode and create a few Looks to prove that the truss can move as required above. 
For details on creating Looks, see the wysiwyg online Help or Reference Guide.

Before you begin, from the Design menu, click Intensity Tool, Focus Tool, and Moving Scenery Tool.

Look 1- Low Horizontal: Start by creating a new Look called 
“Low Horizontal” with a Fade Time of 10 and the following param-
eters:

Intensity:  Movers @ Full, 14º ERS @ 0, 19º ERS @ FULL»»
Focus:  Movers @ Ladder»»
Axis:  Truss_Tilt @ 12, Truss_Move @ 0»»

Look 2- High Horizontal: Create a new Look (do not Clone the 
previous one) called “High Horizontal” with a Fade Time of 10 and 
the following parameters:

Intensity:  Movers @ Full, 14º ERS @ FULL, 19º ERS @ 0»»
Focus:  Movers @ Ladder»»
Axis:  Truss_Tilt @ 12, Truss_Move @ 100»»

Keeping the Ladder Lit

As you move between these Looks and the suggested Looks below, you will notice that the moving lights drift away from the ladder, and only fully lock back on it when the 
truss has finished moving. This is not a problem with wysiwyg, per se, but simply the way it works. CAST’s new product, BlackBox, will enable you to constantly keep the 
ladder lit by moving lights even while the truss they are hanging from is in motion!

Tips & Tricks - #1 Continued



© 2009 The official bi-monthly publication for wysiwyg Members 28

Test the Looks
Click on the “Low Horizontal” Look. The truss should begin to move down, while the moving fixtures stay more or less “locked” on the 
ladder. The two ERSs crossfade, so that the 19º fixture is at full (and focused on the ladder) when the transition/move completes.  

More suggested Looks

Here are some ideas for a few other Looks, all with a Fade value of 10. (Naturally, increasing this value will create slower moves, while 
decreasing it will create faster moves.) When creating new Looks that contain motion, it is recommended to always create a new Look, 
as opposed to cloning an existing Look.

“Low Full CW Tilt”:

Intensity:  Movers @ Full, 14º ERS @ 0, 19º ERS @ 0»»
Focus:  Movers @ Ladder»»
Axis:  Truss_Tilt @ 0, Truss_Move @ 0»»

“Low Full CCW Tilt”:

Intensity:  Movers @ Full, 14º ERS @ 0, 19º ERS @ 0»»
Focus:  Movers @ Ladder»»
Axis:  Truss_Tilt @ 24, Truss_Move @ 0»»

“Mid Half CCW Tilt”:

Intensity:  Movers @ Full, 14º ERS @ 0, 19º ERS @ 0»»
Focus:  Movers @ Ladder»»
Axis:  Truss_Tilt @ 18, Truss_Move @ 50»»

“Mid Half CW Tilt”:

Intensity:  Movers @ Full, 14º ERS @ 0, 19º ERS @ 0»»
Focus:  Movers @ Ladder»»
Axis:  Truss_Tilt @ 6, Truss_Move @ 50»»

ISSUE 25 /JULY 2009
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To download the sample file for this tip, please click here.

http://theplan.wysiwygsuite.com/issue25/Tip1_July2009.wyg
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TIP 2 - In-Depth Look at Release 24’s Consolidate Mesh Feature
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Tips & Tricks- Continued

In the May issue of The Plan, the second tip described how to optimize performance in files by creating new Library Items. At the time, 
we promised that Release 24 would feature a new and even more efficient way to optimize files called Consolidate Meshes.  

While the two methods are similar in what they achieve, consolidating meshes has a very large advantage over creating new Library 
Items: the size of your file does not increase. 

To help you use this new feature, Release 24 also offers a new Visual Style (Bounding Boxes) that enables you to easily determine 
which objects need to be optimized and which do not.  

The Consolidate Mesh feature helps increase performance in Shaded Views by enabling you to “transform” complex objects made up 
of multiple polygons into objects that behave as a single entity. wysiwyg, like AutoCAD and all other similar applications, handles single 
objects comprising many components much better than it handles each of the components separately. In other words, a file that con-
tains twenty risers each made of six surfaces is less efficient, and thus slower, than a file that contains the same twenty risers combined 
into a single object.

The easiest way to determine which objects in your scene to consolidate is to enable the new Object Bounding Box visual style (avail-
able in Release 24) on the View Options tab, as shown below:

http://theplan.wysiwygsuite.com/issue24/ThePlan_%20May09-Tips&Tricks.pdf
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Tips & Tricks - #2 Continued

Once enabled, bounding boxes appear around all items in the Shaded view. Those objects with a high number of bounding boxes are 
all candidates for having their meshes consolidated.  

To optimize your file by consolidating meshes, it is best to work in Quad (CAD mode) because it is much easier to look at what needs to 
be consolidated and have the ability to select and consolidate the object(s) right away, than to flip back and forth between Shaded and 
Wireframe views.

Once you determine which objects to consolidate, perform the procedure below. 

To use the Consolidate Mesh feature

In a wireframe view, select the object that you want to consolidate.1.	
From the Tools menu, select Consolidate Mesh.2.	

Result: A message box appears, confirming that the operation is complete, and displaying the number of polygons that have been 
removed from the file.

Click OK. The item is now consolidated into an object, which 3.	 wysiwyg “sees” as a single entity.

Helpful Tips

It is important to learn to use this feature properly. Let’s take as an example 
a theatre that includes audience seating comprising chairs from the wysiwyg 
library. Since these objects are already optimized (i.e., wysiwyg sees them as 
single entities, not as separate components made up of armrests, backs, legs, 
and so on), there is, seemingly, nothing left to consolidate. 

However, all these seats were placed in the theatre individually, whether they 
were copied & pasted, arrayed, and so on. As a result, wysiwyg still considers 
them to be individual entities. To optimize this file, therefore, you could select 
all the seats (or, if more control over overall placement is required, select all the 
seats within a seating section) and Consolidate them into one large object.

A similar example involves seats that were created in AutoCAD or SketchUp and imported into wysiwyg. In such a case it is recom-
mended that you consolidate a single seat, copy and paste it around or array it to create the seating sections, and then consolidate the 
sections (or all the seating at once) to further optimize the file. If, on the other hand, the imported AutoCAD/SketchUp file contained all 
the seating in the theatre, I recommend consolidating the sections (or all the seating) directly, instead of consolidating individual seats.

Since objects to consider for consolidation can be virtually anything, it is pointless to provide a list of what to look for. The best practice 
is to always turn the Bounding Box view style on once the venue/set in your file is nearing completion (and before you start defining 
hang structures and hanging fixtures), and then optimize as much as possible.

Consolidated Mesh and Improved Shaded View Performance

Once you have consolidated various objects in your file, you will 
immediately notice that the Shaded view has become faster. To 
test this, click and drag within the Shaded view. 

Another way to see the improved speed is to enable View Statistics 
on the View Options tab. If you do so before you start optimizing, 
there is a good chance that the View Complexity will read ‘High’ 
or ‘Very High’. Once you’ve consolidated a few objects however, 
not only will the View Complexity drop to ‘Medium’ or ‘Low’, but the 
Number of Objects will also decrease dramatically while the FPS 
counter will 

Even More Noteworthy Tips
 
Objects that have been modified with wysiwyg’s Boolean tools need not be consolidated since all Boolean operations perform the consolidation automatically.

Objects that have been consolidated cannot have Boolean operations performed on them. This is by no means a flaw or a limitation of wysiwyg’s Boolean tools, but simply the way in 
which 3D models work:  when an object is consolidated, its underlying geometry is modified in such a way that no further geometry changes may be performed on that object.

If an object to which a texture has been applied is consolidated, the texture will most likely not behave correctly. This is, again, due to the object’s underlying geometry having been 
altered in such a way that it cannot support textures properly. To maintain proper texturing AND have the file perform well for pre-visualization, the only thing to do is create a copy of 
the final file, optimize the copy, and then use the optimized file for pre-programming purposes and the original file for screenshots and/or renderings


